MPTCFS_SA~ doesn't understand "absolute_mode_control&qu

For topics related to using MsPinky inside the Max/MSP graphical programming environment
billzillski
Posts: 2
Joined: Mon Jan 25, 2010 2:30 pm

MPTCFS_SA~ doesn't understand "absolute_mode_control&qu

Postby billzillski » Tue Dec 27, 2011 11:49 pm

I am having problems getting this running. I know I've had it working before but it has been a while.
When using the Pinky M4L device or the Revised one, I get the error message in Max's message window saying:

MPTCFS_SA~ doesn't understand "absolute_mode_control"
MPTCFS_SA~ doesn't understand "vinyl_control"
none: file not found!

My MPTCFs are from 4/13/2011 and I'm pretty sure they are in the right places. The plugin loads fine, all buttons show up, everything works but the vinyl control. I can see on the left side a signal coming in, and if I click the play button I get a signal and sound coming out. I'm using Ableton with Torq vinyl and the Connective box. Timecode sounds fine to me. If I let the record play with demod on I can see the the position number changing.

Can anyone help me restore my sanity? Please?
Thanks
dlpinkstah
Site Admin
Posts: 1093
Joined: Mon Jun 07, 2004 9:17 pm

Postby dlpinkstah » Wed Dec 28, 2011 10:17 pm

Looks like you must have an outdated version of the patches. The commands to mptcfs_sa~ to set vinyl control were changed about a year ago. So the "absolute_mode_control" and "vinyl_control" have been replaced by the command "control_mode". The newest version of the M4L patch "MsPinky_M4L_AudioFX" which is available from the downloads page shows how to use this command. There is also the reference patch "MsPinky_MPTCFS" which shows how to use this command to set vinyl control modes. If you don't wish to delete the patches you currently have, you can update them to use the new "control_mode" command just by copying exactly the way it's used in the newer patches.
billzillski
Posts: 2
Joined: Mon Jan 25, 2010 2:30 pm

Postby billzillski » Thu Dec 29, 2011 12:39 am

Thanks, recopying over the files fixed it, not sure which one it was but it is working now. Feel pretty dumb. Now if only enjoi or someone would reup the patch that allows multiple instances/decks. Or give me enough hours in a day to figure it out myself.

Thanks again pinky, been a big fan since the early days.

Return to “The Max/MSP + MsPinky = LUV Forum”

Who is online

Users browsing this forum: No registered users and 1 guest